Jitsi-Meet Debian 10 (Buster) „Unable to correct problems“

Since some update of Jitsi-Meet, the actual package has been removed and my instance stopped working. After some investigation I found out that the package is not installed anymore and has been removed.

When trying to reinstall it I encountered the following error:
The following packages have unmet dependencies:
jitsi-meet : Depends: jitsi-meet-prosody (= 1.0.6600-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages."

The issue can be solved by updating prosody to version 12. After that I could install the jitsi-meet package seamlessly.

Step 1:

wget https://prosody.im/files/prosody-debian-packages.key -O /tmp/prosody.gpg.key

Step 2:

cat /tmp/prosody.gpg.key | gpg --dearmor >/usr/share/keyrings/prosody-keyring.gpg

Step 3:

echo "deb [signed-by=/usr/share/keyrings/prosody-keyring.gpg] http://packages.prosody.im/debian oldstable main" >/etc/apt/sources.list.d/prosody.list

Step 4:

apt-get update

Step 5:

apt-get install lua5.2

Step 6:

apt-get install prosody

Step 7: Check installed version

dpkg -l | grep prosody

You should find the following line:
ii prosody 0.12.1-1~buster1 amd64 Lightweight Jabber/XMPP server
0.12 indicates that version 12 is now installed. Now you can run the installation from the Jitsi documentation (apt install jitsi-meet).


Keine Antworten

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert